


About Using Visio Shape Explorer
    How to
    Related Topics

Visio Shape Explorer provides an easy way to search for and catalog Visio shapes, stencils, and 
templates. When you want to find a shape, but aren’t sure which stencil it’s on, you can quickly search 
with Shape Explorer instead of opening multiple stencils. For example, if you know a 3-D Box shape 
exists, but don’t know where to find it, use Shape Explorer to determine which stencil contains the shape, 
then open the stencil or use Shape Explorer to add the shape to your drawing.

In addition to finding shapes on stencils, you can

• Search for templates that are associated with a particular drawing category, such as Basic Network 
Shapes.

• Find out whether or not a certain shape, drawing type, or product is available on the Visio Solutions 
Library Web site.

• Generate a database of shapes, stencils, and templates you created with any Visio product, so you 
can include your own custom database in searches.

How Shape Explorer works

Shape Explorer searches a database that contains the shapes, stencils, templates, and wizards that are 
provided with current Visio products. By default, Shape Explorer searches everything in the database, 
however, you can set your own search parameters to narrow or broaden the scope of a search.

Database fields and categories

You can change the scope of a search by specifying the categories, and fields within those categories, 
that you want Shape Explorer to search.

Shape Explorer can search the following categories:

• Shapes

• Stencils

• Templates

• Wizards

• Products 

Within each category, Shape Explorer can also search the following database fields:

• Name

• Description (or Status Bar Text)

• Keyword



Searching with Visio Shape Explorer
You search with Shape Explorer by typing the search phrase you want to use in the Search For box on 
the Search tab. A search phrase can be a shape or stencil name, or a word or phrase that describes the 
shape you’re looking for or the type of drawing you want to create. 

Examples
• If you want to search for a workstation shape, you can type “computer” to find all related shapes and 

the stencils that contain them. 
• If you want to search for shape categories, for example, you can type “TQM” in the Search For box to 

find all shapes associated with Total Quality Management.
• If you’re creating a diagram of your company’s network, you can type “network” to find all items that 

contain the keywords “network,” “networks,” and “networking.”

To search with Shape Explorer:

1. On the Search tab, in the Search For box type a name, or a word or phrase that describes what you 
want to find. 

2. If you want Shape Explorer to match the word or phrase you typed exactly, for example, to search for 
items associated with the word “station” but not those associated with “substation,” check Match Exact
Word Or Phrase to narrow your search. 

For more information on how to narrow a search, click Search Tips. 

3. If you want to search for specific categories, for example, shapes and stencils only, click the Refine 
Search tab.

4. Click Find Now.

Shape Explorer searches the categories you specified for items that contain the word or phrase you 
typed. The status bar at the bottom of the Shape Explorer window indicates the progress of the search.

When Shape Explorer completes the search, it displays the results in the lower half of the window. The 
left side shows the categories: Shapes, Stencils, Templates, Wizards, and Products. The right side 
displays the shape and file names of each category. Click the category to display the shape or file names 
that match your search. You can then use the commands on the shortcut (right-click) menu to add the 
selected item to a drawing, open the stencil that contains it, or create a new drawing or stencil.
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Using the Refine Search tab to define search parameters
Visio Shape Explorer searches all categories for the keyword or phrase you type. You can narrow the 
scope of a search by changing the parameters on the Refine Search tab. For example, you can search for
shapes only or just for stencils and templates that match the keyword or phrase you type. Additionally, 
you can specify the database fields you want Shape Explorer to search within each category.

You can search using only one, or any combination of, the following categories:

Shapes
A shape, in the Results Categories list, refers to a master shape. Master shapes are Visio shapes that are
contained in stencils. You drag master shapes from a stencil to the Visio drawing page to create a Visio 
drawing. To include master shapes in your search, under Result Categories, check Shapes. To exclude 
shapes from your search, uncheck Shapes.

Stencils
A stencil is a collection of master shapes that are associated with a particular drawing type. To create a 
drawing, you drag shapes from the stencil to the drawing page. Stencils are stored in stencil files (with 
a .vss extension). When you create a new drawing based on a template, the template opens stencils that 
are related to the template's drawing type. You can also open a stencil file independently of a template. To
include stencils in your search, under Result Categories, check Stencils. To exclude stencils from your 
search, uncheck Stencils.

Templates
A template is a Visio file that opens one or more stencils and can contain styles and settings for a 
particular kind of drawing. You can create a new drawing with a specific template's styles and settings by 
opening that template. To include templates in your search, under Result Categories, check Templates. To
exclude templates from your search, uncheck Templates.

Wizards
A wizard is a Visio tool that automates common tasks. For example, you can use the Org Chart Wizard to 
automate creating an organization chart. To include wizards in your search, under Result Categories, 
check Wizards. To exclude wizards, uncheck Wizards.

Products
To exclude Visio product names and definitions from your search, uncheck Products.

To define search parameters:

1. Click the Refine Search tab.

2. Check the categories you want to include in your search.

3. Uncheck all categories you do not want to include in your search.

4. To specify the database fields within each category to search, click the Details button.

5. Click Find Now.

Shape Explorer searches the categories you specified for items that contain the word or phrase you 
typed.
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Narrowing your search using database fields
For each category on the Refine Search tab, you can specify the database fields that Shape Explorer 
searches. Simply select a category in the Result Categories list, and click the Details button.

Within each category, you can search the following fields for your search word or phrase:

• Name (or Shape Name): When checked, Shape Explorer searches the name of the item to see if it 
matches the search phrase.

• Description (or Status Bar Text): When checked, Shape Explorer searches the description field for 
the search phrase.

• Keywords: When checked, Shape Explorer searches the Keywords field to see if the search phrase 
matches any of the keywords you specified.

To specify the database fields to search:

1. On the Refine Search tab, select the category for which you want to specify database fields.

2. Click Details.

3. Check the database fields you want to include in your search.

4. Uncheck all fields you do not want to include in your search.

5. Click OK.
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Search tips
    How to
    Related Topics

Visio Shape Explorer provides tools you can use to narrow or broaden the scope of a search for specific 
Visio shapes, files, or products.

Match Exact Word Or Phrase checkbox
When you check Match Exact Word Or Phrase, Shape Explorer only returns results that exactly match 
the words in the sequence you specify. Putting quotation marks around a phrase has the same effect as 
checking Match Exact Word Or Phrase.

Examples
• If you type “flow diagram” and check Match Exact Word Or Phrase, Shape Explorer returns only items 

that literally match “flow diagram.” If you do not check Match Exact Word Or Phrase, Shape Explorer 
returns all items that include “flow” and “diagram,” even if the two words are not next to one another.

• If you type “station” and check Match Exact Word Or Phrase, Shape Explorer returns “Station,” “Gas 
Station,” and “Transfer Station,” but does not return “Workstation,” “Substation,” “Stationary Front,” 
and so on.

AND operator
You can use the AND operator to narrow a search. When you type an AND, Shape Explorer returns only 
those items that contain all the words you have joined using AND. You can use one AND operator in your 
search phrase or you can use multiple AND operators.

Example
• Concentric AND Circle: Shape Explorer finds shapes named “concentric circle” or items that contain 

both words, such as “Concentric 1-D circles.”

OR operator
You can use the OR operator when you want to broaden a search. When you type an OR, Shape 
Explorer returns all the items that match any or all of the words in your search phrase.

Example
• Concentric OR Circle: Shape Explorer finds shapes named “Concentric circle” or items that contain 

one or both words, such as “Concentric 1-D circles,” “Art Deco circle,” “Circle callout,” and so on.

Wildcard searching
When you type a keyword to use in your search, Shape Explorer automatically treats the keyword as a 
truncation of a larger word or a wildcard search unless you check the Match Exact Word Or Phrase 
checkbox. You can use this functionality to broaden your search, by typing in a portion of a word to find all
forms of that word. To limit your search to the exact keywords you typed, you must check Match Exact 
Word Or Phrase.

Example
• Network: Shape Explorer finds all items containing “network,” “networks,” and “networking.” If you 

want to find items containing “network” only (and not “networks” or “networking”), check Match Exact 
Word Or Phrase.



About creating a custom user database
    How to
    Related Topics

You can narrow or broaden your search by creating one or more custom user databases tailored to your 
specific needs. 

Examples
• You can create a database of the Visio files on your computer so that you can search only your files.
• You can create a database that includes all the shapes, stencils, and templates you’ve created in Visio.
• You can create a database that includes stencils and templates you’ve updated with your own 

keywords. Keywords let you search for stencils and templates in terms you define.





Creating a custom user database 
To create a custom user database: 

1. Choose File > New User Database.

2. In the Database Name box, type a name for your database.

3. Under Save Database In, specify the folder in which to save your database.

4. Click OK.

Shape Explorer asks if you want to add files to the new user database now.

5. Click OK.

6. To select specific files, such as stencils, templates, or Wizards, click Browse under Select By File, and 
then do the following:

• Under Files Of Type, select the specific type of Visio file to add to your database, or select All Visio 
Files.

• Under Look In, select the folder that contains the files you want to add.

• In the Look In list, choose the file you want to add, then click Open.

• Repeat to add more files.

or

To select an entire folder of Visio files to add, click Browse under Select By Folder, then do the 
following:

• Under Selected Folder, select the folder that contains the files you want to add. 

• Click OK.

• To also include the Visio files in all subfolders below the selected folder, check Include Subfolders.

7. Click OK.

Shape Explorer creates your custom user database. Depending on the number of files added and the 
speed of your computer, this can take up to half an hour.
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Adding files to an existing custom user database
Before you add files to an existing custom user database, you must specify the database to add files to in 
the Database Options dialog box. You can only add files to a custom database created in Shape Explorer.

To add files to an existing custom user database: 

1. Choose Tools > Database Options.

2. Make sure the database you want to add files to is listed in the Location box under User Database. If 
the database isn’t listed, click Browse and navigate to the folder that contains the custom database 
you want to add files to.

3. Click OK.

4. Choose Tools > Add Files.

5. To select specific files, such as stencils, templates, or Wizards, click Browse under Select By File, then 
do the following:

• Under Files Of Type, select the specific type of Visio file you want to add to your database, or select
All Visio Files.

• Under Look In, select the folder that contains the files you want to add, choose the specific file to 
add, and then click Open.

• Repeat to add more files.

or

To select an entire folder of Visio files to add, click Browse under Select By Folder, then do the 
following:

• Under Selected Folder, select the folder that contains the files you want to add.

• Click OK.

• To also include the Visio files in all subfolders below the selected folder, check Include Subfolders.

All stencils, templates, and add-on files in the selected directory will be added to the database.

6. Click OK.

Shape Explorer updates your custom user database with the new files. Depending on the number of 
files added and the speed of your computer, this can take up to half an hour.
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Adding your own keywords to Visio stencils
You can add keywords to the Properties dialog box for Visio stencils and templates that you add to your 
custom user database. Keywords let you search for stencils and templates in terms you define.

By default, stencils open as read-only. Before you can add keywords to a stencil's Properties dialog box, 
you must open the stencil as an editable, read/write file. 

To open a stencil as read/write and add keyword properties:

1. In Visio, choose File > Stencils > Open Stencil.

2. Open the Solutions folder, then open the folder that contains the stencil you want to open.

3. Select the stencil (.vss file). Under Open, select Original, then click Open.

This opens the original stencil file that comes with the Visio product. 

If you want to keep the original file intact, select Copy, then click Open. If you select Copy, you must 
save changes to the stencil under a new name. After saving your changes, you must add the new 
stencil to your custom user database so you can include it in searches.

4. Click the stencil title bar to make it the active window, then choose File > Properties.

5. In the Properties dialog box, under Keywords, add the terms you want to use to search for items on 
that stencil. Type a comma (,) between terms to separate them.

6. When you are finished adding keywords, click OK to close the Properties dialog box.

7. Choose File > Save As, then, in the Save As dialog box:

• Under Save As Type, select Stencil (*.vss).

• Under Save In, select the folder in which you want to save the stencil.

• Under File Name, if you opened the original stencil, that name appears. If you opened a copy of the
stencil, type a new stencil name.

8. Click Save to save the stencil with your keywords.
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Choosing the database you want to search
When you search using Shape Explorer, you can search the database provided with Shape Explorer, any 
custom database that you have created, or both. The database provided with Shape Explorer contains a 
listing of all the shapes, stencils, templates, add-ons, and Wizards that come with current Visio products. 
You can choose to search all products or you can narrow your search to a single product, such as Visio 
Technical.

Alternatively, you can create and search your own custom user database. For example, you may want to 
create a database that contains only the shapes, stencils, and so on for the Visio products that you have 
installed on your computer. Or, if you’ve created a number of custom templates, stencils, and shapes, you
may want to include these in a custom database that you can search.

To choose the database you want to search:

1. Choose Tools > Database Options.

2. Under Visio Products Database, check Include In Search to search the database provided with Shape 
Explorer.

In the Visio Products To Search box, select All Products to include all Visio products in your search, or 
select a specific product to narrow your search.

3. Under User Database, check Include In Search to search a custom database you’ve created.

To specify the location of the custom database, type the path in the Location box, or click Browse and 
navigate to the folder that contains the custom database.

4. When you’re finished specifying database options, click OK.
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Command Reference

To display help for a command while working in Visio, highlight the command, and then press the F1 key. 

A
About Shape Explorer

Add Files

Add To Drawing

B
Browse Info

C
Create New Drawing

Create New Stencil

D
Database Options

Details

E
Exit

L
List

N
New User Database

O
Open Containing Stencil

Open Containing Template

Open Stencil

Open Template

P



Properties

R
Run Wizard

S
Shape Explorer Help





New User Database
    Related Topics

File menu
Opens the Create User Database dialog box in which you can specify a name and location for a new 
custom user database. If you specify a file name and then click OK, Shape Explorer asks you if you want 
to add files to your database. If you choose OK, the Select Files To Add dialog box opens.





Exit

File menu
Exits Shape Explorer.





List
    Related Topics

View menu
Displays the results of your search as a list.





Details
    Related Topics

View menu
Displays the following information about each of the items in the Search Results list: the name of the item;
the product, stencil, and template in which the item is found, if applicable; a description of the item; and 
the product URL.





Add Files
    Related Topics

Tools menu
Displays the Select Files To Add dialog box in which you can specify which Visio files you want to add to 
your custom user database. You can add files individually or by folder. If you haven’t created a custom 
user database yet, Shape Explorer asks if you want to create one, then opens the Create User Database 
dialog box.





Database Options
    Related Topics

Tools menu
Displays the Database Options dialog box in which you can specify whether you want to search the 
database provided with Shape Explorer, your own custom database, or both.





Shape Explorer Help

Help menu
Displays online help for Shape Explorer.





About Shape Explorer

Help menu
Identifies the version of Shape Explorer you are using and displays copyright information. 





Add To Drawing

Shortcut menu
Adds the selected shape to the active Visio drawing. This command is available only when a shape is 
selected in the Search Results list.





Open Containing Stencil

Shortcut menu
Opens the stencil in Visio that contains the selected shape. This command is available only when a shape
is selected in the Search Results list.





Create New Stencil

Shortcut menu
Creates a new stencil in Visio and adds the selected shape or shapes to the stencil. This command is 
available only when a shape is selected in the Search Results list.





Browse Info

Shortcut menu
Launches your Web browser and connects you to the area of the Visio Web site that contains information 
about the selected item.





Properties

Shortcut menu
Displays the Properties dialog box for the selected item. The Properties dialog box contains a description 
of the selected item and where it can be found (stencil, template, or product). If the selected item is a 
shape, you can view the shape in the Properties window by clicking the Show Preview button.





Open Stencil

Shortcut menu
Opens the selected stencil in Visio. This command is available only when a stencil is selected in the 
Search Results list.





Open Containing Template

Shortcut menu
Opens the template in Visio that contains the selected stencil. This command is available only when a 
stencil is selected in the Search Results list.





Create New Drawing

Shortcut menu
Creates a new drawing in Visio and opens the selected stencil in the Stencil window. This command is 
available only when a stencil is selected in the Search Results list.





Open Template

Shortcut menu
Opens the selected template in Visio. This command is available only when a template is selected in the 
Search Results list.





Run Wizard

Shortcut menu
Runs the selected wizard. This command is available only when a wizard is selected in the Search 
Results list.




